Forums Home
 

Reply
 
Thread Tools Display Modes
Old 10-Nov-2011, 6:31 pm   #1
FaultWire
Moderator
 
FaultWire's Avatar
 
Join Date: Mar 2008
Posts: 12,981
Invalid Android AVD Error - No compatible targets were found. Do you ...

Dialog text:
No compatible targets were found. Do you wish to a add new Android Virtual Device?

Issued by: Windows 7, Java(TM) Platform SE 6 U22
Vendor: Sun Microsystems, Inc.

Jump to the FaultWire page for Solutions and Fixes for this topic...

FaultWire is offline   Reply With Quote
Old 14-May-2012, 10:37 pm   #2
mvarithy
New Member
 
Join Date: May 2012
Posts: 1
Message Android virtual device found

hi,
wit regard to the thread that discussed abt the error of no compatible targets found could be solved by manually selecting a lower version of avd.

i.e if you are using 4.0.3 android platform, create a new avd in 2.1 version. It worked for me.

But here is my doubt... how can I use the latest avd version then..? like I'm working on a android app that requires 4.0.3. Wat do I do then..?
mvarithy is offline   Reply With Quote
Old 18-May-2012, 10:26 am   #3
frankvg
Administrator
 
Join Date: Feb 2008
Posts: 12
Thumbs Down

Your instructions are in the right direction. First you need to find the version your project is built for. To do this in Eclipse:

From the menu: Project -> Properties, and select "Android" in the left box. This shows what the project is being built for. For example "Android 2.3.3".

Close the dialog.

Next, from the menu: Window -> AVD manager and check that an AVD is available for that version. Likely there is not one that matches, and you'll need to add a new one.

To add a new one, press New... and fill out the new AVD info. You can give it any name, but be sure to select the Target to match the project version.

When done, note the API Level for this newly created AVD. In this example, version 2.3.3 is API level 10.

Confirm your AndroidManifest.xml file also specifies the minimum version that is equal to or below the project. For this example, it would appear as a line, typically after the android:versionName line as:

<uses-sdk android:minSdkVersion="10" />

Any number 10 or below is fine.
frankvg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. This page opened at 5:16 pm.


 
  Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.